Friday, February 15, 2013

Tabs on Top and Windows test build

Development is moving towards next release, 1.4.0.

Tabs on Top
The latest thing added worth noting is option to move tabs on top. It has been requested in issue tracker (#640) and is now fully implemented.
This feature is, of course, only optional, so that means you don't have to use it if you don't like it. Tabs on top are also not enabled default.

Tabs on top

Windows test build
I have finally succeeded in building QtWebKit 2.3 for Windows. Next version will then be shipped with the latest version of QtWebKit.

Current build (February 18 27cd8cce64): Download (zip)

Notes to this build:
 - it now actually should run even on Windows 2000
 - updated OpenSSL to 1.0.1e
 - updated QtWebKit with Page Visibility API support
 - only English dictionaries in zip (all languages will come with release)

String freeze
String freeze is planned by the end of this week and new version will be released by the end of the February.
Update: String freeze February 19

44 comments:

  1. Thank you very much for the new build. Spell checking support is much appreciated(!). I hope the final build is available with more dictionaries by default (just like the GUI).

    If only it supported opening a MHT files I would get rid of Opera completely...

    There is a problem with this build. I've downloaded the archive and extracted it onto HDD, but QupZilla 1.4 beta can't run on Windows 7 64 bit Polish UI. I've tried to run the exe as Admin, in Compatibility mode and so on, but I get:

    'qupzilla.exe - Application error
    Application wasn't launched correctly (0x000007b). Click OK button to close it'

    Any ideas how to fix it? Thanks

    ReplyDelete
    Replies
    1. Hi,
      you may need to install MSVC redistributables.
      http://www.microsoft.com/en-us/download/details.aspx?id=5555

      There may be also other issues with libraries coming from the fact that this QtWebKit build is with WebGL enabled and thus linked against ANGLE (and ANGLE against d3d)

      This won't be in release.

      Delete
    2. The setup has detected that a newer version of this software has already been installed on my system, so I can't continue the installation. Thanks for the help anyway.

      Delete
    3. So it must be because of WebGL "support".
      I will upload new build as soon as I get to my Windows machine (which won't be sooner than by the end of this week)

      Delete
    4. I've fuinally fixed the issue by installing this from Windows Update:
      http://support.microsoft.com/kb/2565063

      QupZilla has been working as expected so far. If I found any issue, I'll give some feedback here.

      Delete
    5. I have same problem on Windows. QupZilla can't run.
      I get newest MSVC redistributables(x86 and x64), but it can't startup...

      Delete
  2. On Windows 7 x64, i can use chinese UI as normal, but this build very slow, always needs refresh page.

    ReplyDelete
  3. Dear David, win32 OpenSSL Updated to v1.0.1e,
    http://slproweb.com/products/Win32OpenSSL.html
    Lib files here:
    http://rghost.net/43788242

    ReplyDelete
    Replies
    1. Hi,
      thanks for info. I will update it in release build.

      Delete
  4. Unbelievable, i restart my computer, now new build runs pretty fast.
    Sorry for wrong information. ^^

    That's a little strange.

    ReplyDelete
  5. - builded with WebGL support, but it crashes on every WebGL page

    WebGL doesn't work, but not always crash. Midori[Win] also added WebGL support, doesn't work either.
    http://twotoasts.de

    Some WebGL website:
    http://bbs.kafan.cn/thread-1309710-1-1.html

    ReplyDelete
    Replies
    1. Compiling shaders doesn't work ... So it's useless.

      Delete
    2. I've finally fixed problem with the QupZilla installation described in the comment no. 1. I run Windows Update and it installed a 'Security Update for MS Visual C++ 2010 with Service Pack 1 (KB 2565063)'.

      QupZilla has been working as expected so far.
      If I found any issues, I'll give some feedback here.
      Thank you for the release!

      Delete
    3. Qt 5.0 has released, it has 64-bit support, with a new webkit which means it support HTML5, unfortuntely quite different to qt4. Dear David, would you have some plan to use Qt5 compile qupzilla?

      Delete
    4. This is QupZilla on Qt 5: https://github.com/QupZilla/qupzilla/pull/706

      So Qt 5 is not even remotely ready for use on desktop.

      Regarding webkit version, QtWebKit 2.3 (in current build) is the same (with more features and bug fixes) than the one in Qt 5.
      The only difference is V8 JavaScript engine and working WebGL in Qt 5.

      Delete
    5. Thanks for explanation, pal.
      Congratulation for this new build by QtWebKit2.3, You paid too many effort for it. Good job!

      Delete
  6. Replies
    1. Thanks for your update. But it doesn't still run on my Windows 7, x64.

      Anyone has same bug?

      Delete
    2. Hi,

      It's great update and I like tabs on top option so much!
      I noticed one issue. If we have a .qupzilla folder made by QupZilla 1.3.5 or older in username folder, QupZilla can't startup on Windows.
      Some contributers know how to fix this issue from github, but users don't.
      So I think you should note how to fix this issue.

      Thanks.

      Delete
    3. This should be fixed in this build. Can you confirm it?

      Delete
    4. Sorry, I was wrong.
      This issue is from my PC...
      Probably, it caused by EMET (or other security software) on my PC.
      I confirmed that QupZilla can startup with it disabled.
      Thanks your pointing out.

      Delete
    5. umm...
      I'm really sorry. This issue may not be come from EMET.
      It seems that this issue is caused by my own profile(.qupzilla) folder.
      *This profile folder was made by QupZilla 1.3.0.

      I tried to make QupZilla 1.4.0 test build startup with my profile folder, and can not.
      But 1.3.5 can startup with.

      Should I send my profile folder for you?

      Delete
  7. This build runs much smooth than test1, and less crash.

    ReplyDelete
    Replies
    1. Hi,
      can you please post all sites that crashes at issue tracker?
      Thanks

      Delete
  8. i've tried all history web site, no more crash, sorry i couldn't remember those, maybe 3 - 4 site.

    ReplyDelete
  9. Hi,David Even in this version i am not able to view e paper of www.andhrajyothy.com.Where as i am able to view with Flashpeak Slimboat built with qt.I donot know why.

    ReplyDelete
    Replies
    1. Can you send me the error on e-mail?
      Thanks

      Delete
    2. Hi David ,i have sent you a email.By the by my system is windows 7 32 bit.

      Delete
  10. Dear David, this build can't use ftp.
    such as
    ftp://ftp.kddlabs.co.jp/graphics/ImageMagick/
    ftp://ftp.fifi.org/pub/ImageMagick/

    ReplyDelete
    Replies
    1. These ftp's are working correctly for me with current build (on Windows, Linux and also Mac)

      Delete
    2. It's OK now. So strange. i checked other QT web browser could but this build couldn't yesterday.

      Dear David, does qupzilla has some easy way to change proxy? you know, we have to change proxy very often in china. May you could add hotkey or button[optional] for us?

      Delete
  11. Other user report:
    Use greaseMonkey plugin, when delete script, cause this build crash.

    ReplyDelete
    Replies
    1. Thanks for the report, it is fixed now.
      But please report bugs at issue tracker at github.

      Delete
    2. Mostly windows user feels a little unfamiliar to github. :)
      Ok, i'll trick them to use it.

      Delete
  12. Now this is browser that has very bright future,it can compete with any "mainstream" browser out there,and it is winning XD... Light,simple,pretty good features,very fast and stable. Talking about stability,i see(in change-log) that 1.4 version has important bug fixes and new features,where can i download up2date test 1.4 version for ubuntu?

    ReplyDelete
  13. Gosh your web-browser rocks. It's beautifull, well-integrated with KDE, have greasemonkey and adblock by defaut and what I love the most is how fast and light it is!!! I used it since the first versions and am really happy to see how far you've been. (I tend to use it more than firefox)

    ReplyDelete
  14. +1, QupZilla runs very nicely on Linux systems, and it fits really well in KDE : goodbye Konqueror & Rekonq ;-)

    Awaiting the upcoming 1.4.0 !

    ReplyDelete
  15. David if you plan to use QT5 in future please do not force GPU requirement so every person can run QupZilla.

    ReplyDelete
  16. Any chance of WebKit2 integration soon? Things like the NFL Social game on Facebook use over 300MB of RAM in QupZilla while some browsers are only using around 170MB.

    ReplyDelete
    Replies
    1. WebKit2 is only available with QML with Qt 5. It will probably never be in QupZilla.

      And WebKit2 is multi-process, so the memory usage would even increase with using it.

      Delete
  17. This comment has been removed by the author.

    ReplyDelete
  18. I absolutely love this browser, really nice features, lightweight, very fast (special mention for Speed Dial, it's really top-notch and very elegant).
    I'm impatiently waiting for the upcoming 1.4.0 :)

    Best regards,
    Guillaume

    ReplyDelete
  19. I see that development of 1.4.0 took much longer time,than it was expected,any fresh news about final build possible release date?

    Btw. i have 1 question: Is there option to turn on spell checking(eng),or some other work around for that option? I use ubuntu linux

    Keep up a good work :)

    ReplyDelete